How can I downgrade my Flutter version?

Benson Arafat
2 min readAug 15, 2023

When there is a new flutter version, we all know what to do right? We run the flutter cli command which is ``` flutter upgrade``` and this will download the new update right into our local machine.

Now, here is the catch you want to work with the previous version, you could also do the opposite of what you did, which is to run the flutter cli command on your terminal ```flutter downgrade``` but the problem with this is that you will about to downgrade to the next previous version. What if you want to downgrade to v3.0.0 or v2.0.0 this won't work for you.

They are two ways we could use the previous version of Flutter.

Download SDK and Unzip: Download any version you want from the Flutter SDK archive, unzip the file after you download and use make use of that it. But I won’t do this, I will just compile so many versions on my computer.

Downgrade using the CLI: The second way, this can be done is by using the cli to downgrade to any flutter version using the flutter step:

  1. change the directory to your flutter SDK path i.e cd [your flutter SDK path]
  2. Nex, git checkout [enter your version ref]. You can get the ``ref`` from the Flutter SDK archive, select any version you want to downgrade to and copy the ref.
If I want to downgrade to v3.0.0

3. Finally, I will just run ```flutter doctor``` and that’s all I have to do.

Thanks. Cheers. 🍻🥂

--

--